Du bist nicht angemeldet.

Eine Antwort schreiben

Schreibe deinen Beitrag und versende ihn
Beitragsoptionen
Bist Du ein Mensch oder ein Roboter ?

Verifizierung, dass diese Aktion durch eine reale Person vorgenommen wird und nicht von einem Programm.

Zurück

Themen-Übersicht (Neuester Beitrag zuerst)

Ronny
Heute 00:40

@ KI-Werbung
Sie sucht die Werbung entsprechend ihrer "Quotenschaetzer" ab (die auch abhaengig der Risikobereitschaft angehoben werden). Dabei werden Abstriche gemacht, falls Werbung "draengelt" - sprich je weniger Zeit fuer die Vertragserfuellung ist (auch einbezogen: Anzahl noch zu sendender Spots), desto hoeher die Prioritaet dieser Werbung.

Scheinbar funktioniert das aber nicht so wie gewollt (also laut der Beschreibung zumindest).

Gerne nehme ich einen Speicherstand "vorher" (so, dass die KI noch "umstellen" kann aber man schon sagen kann: "um 12 Uhr sollte Sie lieber Werbespot XYZ nehmen"). Dann kann ich schauen,was da die KI "denkt".



@ Makler
Das liegt an dem Modus...



@ Nachrichten
Also den Nachrichtenmangel hatte ich ja schon behoben - gern packe ich einen neuen DevPatch zusammen.

Die Abonnements - nun, anscheinend sind die KIs der Meinung nicht genuegend vom Budget fuer Nachrichten abknapsen zu koennen. Man laeuft also auf "Sparflamme".

Auch hier - Speicherstand zuschicken.


Vielleicht sollte ich es in den "strg + tab"-KI-Debugbildschirm integrieren, wie die derzeitigen "Budgets" der KI aussehen (also fuer die Unteraufgaben).
Falls jemand den Bildschirm nicht kennt: "strg + tab" druecken und dann mittels der TV-Kanal-Buttons (unten links) den Spieler auswaehlen.


bye
Ron

Ratz
Gestern 22:09

Und dann beobachte ich da gerade noch eine komische KI-News-Anomalie... ich will mal nicht gleich Bug schreien. Wer weiß was ich da wieder angestellt habe - wobei ich mir gar keiner Schuld bewusst bin. gw_smiley_zwinkern

Tag 9 - alle KI's haben nur ein News-Abo > Tagesgeschehen

Alle vernachlässigen ab Tag 9 plötzlich die Pflege und Neuplatzierung der News, senden fast einen ganzen Tag lang den Schnee von gestern.

Viele News kommen durch den Bug zwar nicht mehr rein aber Wetter und Terror läge frisch vor, wird aber kollektiv nicht gesetzt - bis am Ende von Tag 10 plötzlich eine KI wieder anfängt die News zu pflegen.

Wie es mit den Anderen weiter geht? Weiss ich noch nicht ...

[ein Potpourrie an Speicherständen liegt natürlich vor]

Ratz
Gestern 22:00

@ v062 - Dev Patch 26.02.

Die KI im Startjahr 1985 betreibt das "Sender bauen" ganz vorzüglich. Zw. 4,54 und 4,69 Mio Reichweite haben die KI's am Ende von Tag 10 erreicht. Die bevorzugte Platzierung, an Stellen an denen es schon Konkurrenzmasten gibt, fällt sehr auf. Sowas kann einem schon mal die Quoten in der Ramschzeit erheblich verhageln... gw_smiley_zwinkern


@ Balancing fuer "empfundene Qualitaet"

Da Ramschprogramme nun i. d. R. um einiges schlechter geworden sind, leidet das Quotenniveau der KI ganz schön. Erschwerend kommt hinzu, dass sie häufig auf "nicht aufgefrischtes Programmm" zurück greifen.


@ KI-Werbung

Habe eher zufällig bemerkt das bei Quotenschätzung / Werbespotplatzierung tüchtig tief gestapelt wird. Beispielsweise werden Spots mit der niedrigsten Erwartung und längsten Vertragsdauer platziert und die Spots mit hoher aber real erreichter Erwartung, welche dazu noch am Tagesende ablaufen, außen vor gelassen.
So musste in diesem Fall gleich 2x absolut vermeidbar Strafe gezahlt werden.

Hatte sogar ein wenig an der KI-Werbeplanung herumoptimiert - sie hat's aber gemerkt und glatt wieder zurück verschlimmbessert.


@ Werbemakler

Meine Standardfrage: Irgendwas dran rum gescriptelt? smile
Wahrscheinlich liegt's einfach nur daran, das ich, ganz ungewohnt, eine viel geringere Reichweite als alle anderen habe (2,46 Mio).

Die Ramschangebote beinhalten plötzlich vergleichsweise hohe Verträge (Senner Käs / Dörrobst Toni - Niveau), welche dort sonst nie zu finden waren. Im Topsegment fehlen dafür die ganz irre hohen, kaum schaffbaren wie "Raff Gier Banken und Versicherungen" oder "Bonze" (weil die KI ja keine gescheite Primetime sendet). Mir ist's sehr recht - das Maklerangebot ist angenehm breit. smile

Ronny
17.03.2019 21:07

Ich habe jetzt die Klassen fuer die Einstellungsfenster ausgegliedert -
und somit auch in der "Escape-Menue"-Klasse nutzen koennen.

Kurzum: man kann grundlegend die Einstellungen nun auch waehrend des Spiels anpassen.
Werde aber wohl die ganze Einstellungsgeschichte in "Tabs" gliedern - und fuer die Lautstaerke von Musik und Sfx noch "Regler/Schieber" einbinden.

YhXH3VY.png



@ Janko Weber
Fuer was sind die Downloadlinks - ist das fuer dich zum bequemen "auf verschiedene Rechner bekommen"? Die Audiodateien werden auch geladen (bzw sollen geladen werden), wenn man die Musik deaktiviert hat - habe da nicht ueberprueft ob es dadurch abstuerzen kann.


Bezueglich Absturz der 32-Bit Fassung:
- ich kann mit dem neuen Compiler eine 32-Bit-Fassung kompilieren
- ich koennte eine Debugfassung kompilieren und du koenntest mit installiertem GCC dann das Spiel mittels "GDB" aufrufen und sehen wo es abstuerzt

Wenn Du mir dabei helfen woelltest, schreib mir einfach eine mail an ron @ gamezworld.de (weiss nicht ob deine Gast-EMail korrekt ist).


bye
Ron

Janko Weber
17.03.2019 20:50

Die TVTower_v0.6.2-dev_20190311 funktioniert bei mir mit Linux nur wenn ich die Musik in der settings.xml deaktiviere <sound_music>FALSE</sound_music>. Sonst stürzt das Programm ab. So wichtig ist doch aber die Musik in einer Development-Version nicht; somal einige Werke bei mir sehr schräg klangen. Ich werde jetzt die Sache mal ohne Musik auch verschiedenen Rechnern antesten...

TVTower_v0.6.2-dev_20190311_Linux-32bit_Vollbild-800x600_ohneMusik.zip (9.76 MB)
https://www.file-upload.net/download-13540909/TVTower_v0.6.2-dev_20190311_Linux-32bit_Vollbild-800x600_ohneMusik.zip.html
https://filehorst.de/d/cABzCjFv
https://workupload.com/file/qMNM7ahj
https://we.tl/t-VDVUFg6n9f
https://ufile.io/jm4uh

MfG Janko Weber

Janko Weber
17.03.2019 20:42

@Ronny
Ich habe auf meinen neueren Computern in der settings.xml
<sound_engine>AUTOMATIC</sound_engine> in
<sound_engine>LINUX_PULSE</sound_engine> geändert.
Jetzt funktioniert es.
Auf meinem Lieblings-PC Intel Celeron 1200MHz
funktioniert(e) es; ich hatte vermutlich vergessen die Lautsprecherboxen einzuschalten: Bei dem ist es übrigens vollkommen egal welche Sound Engine angegeben ist, es funktioniert immer.
Die aktuellen Dev-Versionen sind jetzt aber interessanter...

MfG Janko Weber

Ronny
16.03.2019 14:48

Fix: [AI] only print a debug message for satellites if there is one. Report: dirkw

Fix: [News] Removed invalid check for empty lists. Fixes "hardly new news" bug. Report: dirkw



Ich denke wir haetten nix dagegen, wenn sich noch ein paar Nachrichten ausgedacht werden wuerden ;-)

In den Let's Plays wird ja doch ab und wann daran herum"gemaekelt", dass sich Dinge sehr schnell wiederholen.


bye
Ron

dirkw
16.03.2019 11:56

Meine Vermutung mit dem Startjahr (= Bug) hat gestimmt: Hab jetzt ein neues Spiel mit Startjahr 1985 angefangen und dort hat die KI schon am 2. Spieltag einen Sendemasten gebaut.

Ronny
16.03.2019 11:29

@ DirkW
EMail mit Speicherstand erhalten

Denke der Fehler liegt ... am Startjahr, denn da gab es noch keine Satelliten. Im KI-Script gibt es diesbezueglich einen Fehler...
Nach dem Fehler hatte ich im Forum ja gefragt. Habe ihn nun selbst gesehen und Fehler innerhalb von ... 20 Sekunden behoben ;-)

1980 gab es fuer die KI noch keinen "besten" Satelliten (oder ueberhaupt einen) und das brachte das Skript zum Straucheln - und statt nur den Teilbereich auszulassen, wurde gleich die ganze "Sendemastkaufen"-Aktion abgebrochen. Kaum behoben, hat die KI zugelangt ;-)



Nachrichten: mit "Tab" im Nachrichtenstudio wird offenbart: bei einigen Genres fehlen Nachrichten - schau ich mir dann zur Mittagszeit noch an.
Will schauen WARUM es keine gibt.


bye
Ron

Ronny
16.03.2019 01:02

Beim Sound kann ich dir leider nicht helfen, hast du denn PulseAudio installiert oder welches "Soundsystem" nutzt Du ?
Ich koennte wohl OSS, Alsa und PulseAudio anbieten.

Oeffne mal "config/settings.xml" und scrolle ganz runter..

	<!-- possible values:
		all:     AUTOMATIC
		linux:   LINUX_ALSA, LINUX_OSS, LINUX_PULSE, UNIX_JACK
		mac:     MACOSX_CORE
		windows: WINDOWS_ASIO, WINDOWS_DS

		attention: program might crash with invalid settings, which
				   enforces you to adjust this file by hand!
	-->
	<sound_engine>AUTOMATIC</sound_engine>

-> oder starte das Spiel wenn moeglich und stelle das direkt in den "Einstellungen" um.


@ 0.6.2-dev
Ja bei den 64bit Versionen wurde ein neuer GarbageCollector + Drumherum ausprobiert. Bin aber derzeit wieder "zurueckgerudert".
Mit einem 32bit-System betrifft Dich das aber nicht (da wird mit dem "legacy Compiler" kompiliert). Stuerzt es mit einem vorherigen Devpatch auch schon ab?


bye
Ron

Janko Weber
15.03.2019 21:56

Ich benutze ein 32-bit Debian-Linux. Der Sound funktioniert bei mir nicht, nicht mit TVTower_Linux32 aber auch nicht mit TVTower_Linux32_noPulseAudio.
Die aktuellste Version TVTower_v0.6.2-dev_20190311.zip stürzt schon kurz nach Programm-Start ab, funktioniert also garnicht.

MfG Janko Weber

Ronny
15.03.2019 20:09

Ron @ Gamezworld.de

Ja Startjahr habe ich immer bei 1985 belassen. Eher gibt es max noch kaum Kabelnetze und Satelliten.

Bye
Ron

dirkw
15.03.2019 17:14

@Ronny: ich habe meinen Spielstand gezippt, an welche E-Mail-Adresse kann ich ihn dir zuschicken?

Ich steh vor einem Rätsel: Meine 3 KI's spielen auch auf "leicht" und ich selbst auf "schwer".

Einziger Ansatz: Ich starte immer mit dem niedrigst möglichen Startjahr, also 1980. Könnte es daran liegen, dass vielleicht andere das Startjahr unverändert bei 1985 lassen und die KI im Jahr 1980 noch nichts baut (was dann ja ein Bug wäre)

Ratz @ work
15.03.2019 15:20

@ Sendemasten

... "meine" drei KI-Kumpels spielen auf Stufe "einfach" und haben am 2. Spieltag allesamt den ersten neuen Mast in Betrieb genommen.

dirkw
15.03.2019 13:30
Ratz schrieb:

Hast Du ein altes Spiel aus dem betroffenen Patchlevel fortgesetzt?

Nein, ich hab das alte TVTower komplett runtergelöscht (mitsamt den Spielständen) und die neueste Komplettversion neu installiert.

Ich hatte zuerst den Verdacht, dass ich vielleicht eine falsche Version installiert hätte, aber nachdem ich die Nachrichten sortieren kann, müsste es schon die aktuelle Version sein.